Project

General

Profile

Feature #5602

Copy full path only copies partial

Added by Luke Mauldin 6 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
-
Target version:
-
Start date:
27.03.2020
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:

Description

When viewing a file (example: https://XXXX/playground/samplerepo/files/bb06dde8cb58aae32ffa52a788c37c58e816934f/Program.cs) and clicking on the button to "copy full path", it only copies "Program.cs" instead of the full url.

Version: RhodeCode Enterprise 4.18.2 Community Edition

CopyPath.png (22 KB) CopyPath.png Daniel D, 27.03.2020 20:36
3068

History

#2 Updated by Marcin Kuzminski [CTO] 6 months ago

This is by design. We made this feature as a result of similar feature available in GitHub, i.e you copy the path to a file path. Maybe the tooltip should be changed to copy file path instead of full which indeed could be confusing.

What do you think?

p.s Thanks for all the Tickets and feedback!

#3 Updated by Marcin Kuzminski [CTO] 6 months ago

  • Assignee set to Marcin Lulek

#4 Updated by Luke Mauldin 6 months ago

Our team does not have experience with Github and so the behavior of the button was unexpected to us. I think that changing the tooltip would help. It would also be nice to have a button that would copy the full URL address of the file to the clipboard instead of having to go to the browser address bar but I do not know how to present that from a UI perspective.

#5 Updated by Marcin Kuzminski [CTO] 6 months ago

  • Assignee changed from Marcin Lulek to Daniel D

#6 Updated by Daniel D 6 months ago

3068

Looking at this i think we can do better here:

Since the Path is copy&clickable (see screenshot) it would be good to remove the spaces between the /so users can easily copy the file path and make the tooltip copy the full url instead which is harder to copy imho.

#7 Updated by Marcin Kuzminski [CTO] 6 months ago

I think this is not intuitive, also changes existing behaviour which we should just now change. I think it makes sense to change the label, and maybe add copy url action next to copy content (there is some space)

Will check with UX and make a final call on this.

#8 Updated by Daniel D 6 months ago

  • Tracker changed from Bug to Feature

#9 Updated by Redmine Integration 6 months ago

  • Status changed from New to Resolved

#10 Updated by Luke Mauldin 6 months ago

Reviewed commit and manually appied the fix to the local instance. Update worked as expected. Thank you!

Also available in: Atom PDF