Project

General

Profile

Bug #5515

PR default reviewer is incorrect

Added by Arun Chandrasekaran 9 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
19.11.2018
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

Raising a PR to a main repo should use the owner of the main repo as the default reviewer. However it is currently using the owner of the forked repo as the default reviewer of the PR.

History

#1 Updated by Daniel D 9 months ago

Are you sure that during your test you didn't use the same account?

e.g if owner of REPO1 is 'admin1' and owner of REPO1_FORK is 'admin2' it means if 'admin1' starts the review he will not be added as reviewer, but a fallback will be used. It's because the same person shouldn't review its own code.

Please provide more details of who was the owner, and who started the review/pull request.

#2 Updated by Arun Chandrasekaran 9 months ago

Yes, I'm sure. Please look at the image below. Here the owner of the fork is Mahesh. He forked my repository and I pushed one of my test changeset to his fork and I asked him to raise a PR to my repo. The screen was captured when he raised the PR.

  1. His user name is mahesh
  2. The fork is in his personal repo.
  3. Author of the PR is shown as mahesh
  4. PR reviewer should've been me, as I'm the owner of the main repo or target repo. But that section contains mahesh - which is a bug.

Does this explanation help?

#3 Updated by Daniel D 9 months ago

  • Status changed from New to In Progress

Ok, confirmed that we use the "current" user instead of target repo owner. Actually in EE edition it's fine, it's a misconfiguration of CE edition. We'll add a fix into the next bugfix release, thanks for posting this !!

#4 Updated by Arun Chandrasekaran 9 months ago

Fantastic!

#5 Updated by Redmine Integration 6 months ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF