Project

General

Profile

Bug #5482

Changing a repo's 'Remote pull uri' in its Settings fails with 'No repo type specified'

Added by Peter Colledge about 1 year ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
26.06.2018
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

Presumed fix:

--- rhodecode/model/validation_schema/validators.py.old 2018-06-29 13:17:56.257500455 +0100
+++ rhodecode/model/validation_schema/validators.py 2018-06-29 10:57:34.197339295 +0100
@@ -89,9 +93,9 @@
             # initially check if it's at least the proper URL
             # or does it pass basic auth

-            MercurialRepository.check_url(url, config)
+            return MercurialRepository.check_url(url, config)
         elif 'svn+http' in url[:8]:  # svn->hg import
-            SubversionRepository.check_url(url, config)
+            return SubversionRepository.check_url(url, config)
         elif 'git+http' in url[:8]:  # git->hg import
             raise NotImplementedError()
         else:
@@ -106,7 +110,7 @@
         if 'http' in url[:4]:
             # initially check if it's at least the proper URL
             # or does it pass basic auth
-            GitRepository.check_url(url, config)
+            return GitRepository.check_url(url, config)
         elif 'svn+http' in url[:8]:  # svn->git import
             raise NotImplementedError()
         elif 'hg+http' in url[:8]:  # hg->git import

History

#1 Updated by Marcin Kuzminski [staff] about 1 year ago

  • Target version set to v4.13

Thanks for reporting this, it been already fixed in default, but we didn't backport this to stable. We're now working on 4.12.4 release which will address this, and one more found problem.

Best

#2 Updated by Daniel D 10 months ago

  • Status changed from New to Resolved

Also available in: Atom PDF