Project

General

Profile

Feature #5469

elastisearch >2.x not supported ?

Added by Gildas Fargeas over 1 year ago. Updated about 1 year ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
17.05.2018
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:

Description

can you confirm that rhodecode index module does not support elasticsearch > 2.x ?
I was expecting to bump to a stable version of elasticsearch (6.x) soon but this seems to be incompatible with the version of python-elasticsearch you are including in rhodecode.
Could that be at least documented because I looked at the doc and nothing seems to exist about elasticsearch version requirement !
I tried with 4.11.6 and 4.12.2 but this is more related to the python module used to this purpose.

History

#1 Updated by Marcin Kuzminski [staff] over 1 year ago

Hi Gildas,

Yes this is true, there are many breaking API changes in latest ES, and this is not yet supported. We're soon to try to have a version switch to support old and new versions.

#2 Updated by Marcin Kuzminski [staff] over 1 year ago

  • Target version set to v4.13

Note:

Think how we can support old/new ES client

#3 Updated by Gildas Fargeas over 1 year ago

good to know :)
that's not urgent but the 2.x seems to be on its way to deprecation so I was going to upgrade this one... I'll wait then.
Don't forget to mention that in the documentation because the 2.x is not really the go-to version these days.
Thanks for the answer

#4 Updated by Marcin Kuzminski [staff] about 1 year ago

  • Priority changed from Low to Normal

Also available in: Atom PDF