Bug #4195

[CE] Internal server error when running indexing

Added by Jozko Debugger about 6 years ago. Updated over 4 years ago.

Target version:
Start date:
Due date:
% Done:


Estimated time:
Commit Number:
Affected Version:


RhodeCode 4.3.0 CE cannot reindex:

administrator@ubuntudesktop:~$ /home/administrator/.rccontrol/community-1/profile/bin/rhodecode-index --instance-name=c ommunity-1 -v
for building full text search
Indexing data types ['commits', 'files']
Internal server error

From log:

2016-08-23 13:11:43.803 ERROR [rhodecode.api] Unhandled exception occured on api call: <function get_repos at 0x7f3452bcacf8>
Traceback (most recent call last):
File "/opt/rhodecode/store/g7wpy1wwscss23348rdpx9pl4196jj2m-python2.7-rhodecode-enterprise-ce-4.3.0/lib/python2.7/site-packages/rhodecode/api/", line 255, in request_view
return jsonrpc_response(request, ret_value)
File "/opt/rhodecode/store/g7wpy1wwscss23348rdpx9pl4196jj2m-python2.7-rhodecode-enterprise-ce-4.3.0/lib/python2.7/site-packages/rhodecode/api/", line 100, in jsonrpc_response
raw_body = render(DEFAULT_RENDERER, ret_value, request=request)
File "/opt/rhodecode/store/incd2pyifnx1i11anwh308gxp16rp957-python2.7-pyramid-1.6.1/lib/python2.7/site-packages/pyramid/", line 81, in render
result = helper.render(value, None, request=request)
File "/opt/rhodecode/store/incd2pyifnx1i11anwh308gxp16rp957-python2.7-pyramid-1.6.1/lib/python2.7/site-packages/pyramid/", line 469, in render
result = renderer(value, system_values)
File "/opt/rhodecode/store/g7wpy1wwscss23348rdpx9pl4196jj2m-python2.7-rhodecode-enterprise-ce-4.3.0/lib/python2.7/site-packages/rhodecode/api/", line 75, in _render
return self.serializer(value, **
File "/opt/rhodecode/store/sibj6lzckxg5qvvrlf6511wl13vb00hb-python2.7-simplejson-3.7.2/lib/python2.7/site-packages/simplejson/", line 386, in dumps
File "/opt/rhodecode/store/sibj6lzckxg5qvvrlf6511wl13vb00hb-python2.7-simplejson-3.7.2/lib/python2.7/site-packages/simplejson/", line 272, in encode
chunks = list(chunks)
File "/opt/rhodecode/store/sibj6lzckxg5qvvrlf6511wl13vb00hb-python2.7-simplejson-3.7.2/lib/python2.7/site-packages/simplejson/", line 644, in _iterencode
for chunk in _iterencode_dict(o, _current_indent_level):
File "/opt/rhodecode/store/sibj6lzckxg5qvvrlf6511wl13vb00hb-python2.7-simplejson-3.7.2/lib/python2.7/site-packages/simplejson/", line 603, in _iterencode_dict
for chunk in chunks:
File "/opt/rhodecode/store/sibj6lzckxg5qvvrlf6511wl13vb00hb-python2.7-simplejson-3.7.2/lib/python2.7/site-packages/simplejson/", line 490, in _iterencode_list
for chunk in chunks:
File "/opt/rhodecode/store/sibj6lzckxg5qvvrlf6511wl13vb00hb-python2.7-simplejson-3.7.2/lib/python2.7/site-packages/simplejson/", line 573, in _iterencode_dict
yield _encoder(value)
UnicodeDecodeError: 'utf8' codec can't decode byte 0xec in position 2: invalid continuation byte


Updated by Marcin Kuzminski [CTO] about 6 years ago


Do you have any NON-ASCII repo names, or authors on any particular repository ?


Updated by Jozko Debugger about 6 years ago

Hi Marcin,
I am not aware of that... only that in some cases, there are characters with diacritics in repo's description (e.g.: "Technické služby").


Updated by Marcin Kuzminski [CTO] about 6 years ago

we'll try to reproduce that, did you tried to only build index on one repo that is causing troubles and for example turning the description into non-ascii ones ?


Updated by Jozko Debugger about 6 years ago

I tried with mapping.ini as follows:

myprojectgroup/myrepo = 1


Issue still remained. Should I try something else?


Updated by Marcin Kuzminski [CTO] over 4 years ago

  • Status changed from New to Closed

Also available in: Atom PDF