Project

General

Profile

Support #4081

Receiving server 500 error when trying to clone repo from windows client using eclipse

Added by Bert Zahniser about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
08.07.2016
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

New install from AWS AMI. Access works through web browser but when attempting to connect via eclipse client, I get a Server 500 error. Relevant entries from log files are below:

======VCSSERVER.log
2016-07-08 09:57:01.969 DEBUG [vcsserver.base] GET GitFactory@/data/BertLogTest with cache:True. Context: 02ed1bb6-1487-453f-a7bd-5b061785fc1f
2016-07-08 09:57:01.970 DEBUG [vcsserver.base] FETCH GitFactory@/data/BertLogTest repo object from cache. Context: 02ed1bb6-1487-453f-a7bd-5b061785fc1f
2016-07-08 09:57:01.970 DEBUG [Pyro4.core] Exception occurred while handling request: Exception("NotGitRepository(u'No git repository was found at /data/BertLogTest',)",)
2016-07-08 09:57:01.981 DEBUG [vcsserver.base] GET GitFactory@/data/BertLogTest with cache:True. Context: 8b4e3fc2-c248-4aa3-ad2e-91d42244632a
2016-07-08 09:57:01.981 DEBUG [vcsserver.base] FETCH GitFactory@/data/BertLogTest repo object from cache. Context: 8b4e3fc2-c248-4aa3-ad2e-91d42244632a
2016-07-08 09:57:01.981 DEBUG [Pyro4.core] Exception occurred while handling request: Exception("NotGitRepository(u'No git repository was found at /data/BertLogTest',)",)
2016-07-08 09:57:02.040 DEBUG [vcsserver.base] GET GitFactory@/data/BertLogTest with cache:True. Context: f2d5bcf8-d37f-46f6-95a4-58cc955e61a4
2016-07-08 09:57:02.040 DEBUG [vcsserver.base] FETCH GitFactory@/data/BertLogTest repo object from cache. Context: f2d5bcf8-d37f-46f6-95a4-58cc955e61a4
2016-07-08 09:57:02.041 DEBUG [Pyro4.core] Exception occurred while handling request: Exception("NotGitRepository(u'No git repository was found at /data/BertLogTest',)",)
2016-07-08 09:57:02.053 DEBUG [vcsserver.base] GET GitFactory@/data/BertLogTest with cache:True. Context: 940ce925-c189-40de-aeec-64c99969fb08
2016-07-08 09:57:02.053 DEBUG [vcsserver.base] FETCH GitFactory@/data/BertLogTest repo object from cache. Context: 940ce925-c189-40de-aeec-64c99969fb08
2016-07-08 09:57:02.053 DEBUG [Pyro4.core] Exception occurred while handling request: Exception("NotGitRepository(u'No git repository was found at /data/BertLogTest',)",)

===============ENTERPRISE.log
2016-07-08 09:57:01.991 INFO [rhodecode.lib.middleware.request_wrapper] IP: 127.0.0.1 Request to /BertLogTest time: 0.024s
2016-07-08 09:57:02.069 INFO [rhodecode.authentication.base] Authenticating user rogott using egg:rhodecode-enterprise-ce#rhodecode plugin
2016-07-08 09:57:02.146 INFO [rhodecode.authentication.plugins.auth_rhodecode] user authenticated correctly
2016-07-08 09:57:02.164 INFO [rhodecode.lib.middleware.simplevcs] Access for IP:127.0.0.1 allowed
2016-07-08 09:57:02.245 INFO [rhodecode.lib.middleware.simplevcs] pull action on svn repo "BertLogTest" by "rogott" from 127.0.0.1
2016-07-08 09:57:02.247 INFO [requests.packages.urllib3.connectionpool] Starting new HTTP connection (1): localhost
2016-07-08 09:57:02.256 INFO [rhodecode.lib.middleware.request_wrapper] IP: 127.0.0.1 Request to /BertLogTest time: 0.218s

========NGINX access.log
###.###.###.70 - - [08/Jul/2016:09:57:01 -0400] "OPTIONS /BertLogTest HTTP/1.1" 401 1108 "-" "SVN/1.8.13 (x64-microsoft-windows) serf/1.3.8 javahl"
###.###.###.70 - rogott [08/Jul/2016:09:57:02 -0400] "OPTIONS /BertLogTest HTTP/1.1" 500 1034 "-" "SVN/1.8.13 (x64-microsoft-windows) serf/1.3.8 javahl"

No messages logged to NGINX error.log

Capture.PNG (116 KB) Capture.PNG Bert Zahniser, 08.07.2016 20:16
1237

History

#1 Updated by Marcin Kuzminski [staff] about 3 years ago

Hi Bert,

There is also Apache2 running that proxies SVN requests could you please check logs from it as well ?

Best,

#2 Updated by Bert Zahniser about 3 years ago

Sure, here are the last relevant lines from the apache2 access and error logs:

==========ERROR.log
[Fri Jul 08 15:48:04.349636 2016] [:error] pid 31704:tid 140345874528000Internal error: [client ::1:36031] Can't open file '/home/rcdev/repositories_store/Test-Group/format': No such file or directory
[Fri Jul 08 15:48:04.349668 2016] [dav:error] [pid 31704:tid 140345874528000] [client ::1:36031] Could not fetch resource information. [500, #0]
[Fri Jul 08 15:48:04.349682 2016] [dav:error] [pid 31704:tid 140345874528000] [client ::1:36031] Could not open the requested SVN filesystem [500, #2]
[Fri Jul 08 15:48:04.349685 2016] [dav:error] [pid 31704:tid 140345874528000] [client ::1:36031] Could not open the requested SVN filesystem [500, #2]
[Fri Jul 08 15:56:00.010641 2016] [:error] pid 31763:tid 140345916491520Internal error: [client ::1:36071] Can't open file '/home/rcdev/repositories_store/BertLogTest/format': No such file or directory
[Fri Jul 08 15:56:00.010672 2016] [dav:error] [pid 31763:tid 140345916491520] [client ::1:36071] Could not fetch resource information. [500, #0]
[Fri Jul 08 15:56:00.010676 2016] [dav:error] [pid 31763:tid 140345916491520] [client ::1:36071] Could not open the requested SVN filesystem [500, #2]
[Fri Jul 08 15:56:00.010680 2016] [dav:error] [pid 31763:tid 140345916491520] [client ::1:36071] Could not open the requested SVN filesystem [500, #2]
[Fri Jul 08 15:57:02.248239 2016] [:error] pid 31763:tid 140345908098816Internal error: [client ::1:36074] Can't open file '/home/rcdev/repositories_store/BertLogTest/format': No such file or directory
[Fri Jul 08 15:57:02.248272 2016] [dav:error] [pid 31763:tid 140345908098816] [client ::1:36074] Could not fetch resource information. [500, #0]
[Fri Jul 08 15:57:02.248276 2016] [dav:error] [pid 31763:tid 140345908098816] [client ::1:36074] Could not open the requested SVN filesystem [500, #2]
[Fri Jul 08 15:57:02.248279 2016] [dav:error] [pid 31763:tid 140345908098816] [client ::1:36074] Could not open the requested SVN filesystem [500, #2]

===========ACCESS.log
::1 - - [08/Jul/2016:15:46:55 +0200] "OPTIONS /Test-Group/Sub-Group/Web-Project HTTP/1.1" 500 421 "-" "SVN/1.9.4 (x64-microsoft-windows) serf/1.3.8 TortoiseSVN-1.9.4.27285"
::1 - - [08/Jul/2016:15:46:55 +0200] "OPTIONS /Test-Group/Sub-Group/Web-Project HTTP/1.1" 500 421 "-" "SVN/1.9.4 (x64-microsoft-windows) serf/1.3.8 TortoiseSVN-1.9.4.27285"
::1 - - [08/Jul/2016:15:46:57 +0200] "OPTIONS /Test-Group/Sub-Group/Web-Project HTTP/1.1" 500 421 "-" "SVN/1.9.4 (x64-microsoft-windows) serf/1.3.8 TortoiseSVN-1.9.4.27285"
::1 - - [08/Jul/2016:15:46:57 +0200] "OPTIONS /Test-Group/Sub-Group/Web-Project HTTP/1.1" 500 421 "-" "SVN/1.9.4 (x64-microsoft-windows) serf/1.3.8 TortoiseSVN-1.9.4.27285"
::1 - - [08/Jul/2016:15:46:57 +0200] "OPTIONS /Test-Group/Sub-Group/Web-Project HTTP/1.1" 500 421 "-" "SVN/1.9.4 (x64-microsoft-windows) serf/1.3.8 TortoiseSVN-1.9.4.27285"
::1 - - [08/Jul/2016:15:46:58 +0200] "OPTIONS /Test-Group/Sub-Group/Web-Project HTTP/1.1" 500 421 "-" "SVN/1.9.4 (x64-microsoft-windows) serf/1.3.8 TortoiseSVN-1.9.4.27285"
::1 - - [08/Jul/2016:15:46:58 +0200] "OPTIONS /Test-Group/Sub-Group/Web-Project HTTP/1.1" 500 421 "-" "SVN/1.9.4 (x64-microsoft-windows) serf/1.3.8 TortoiseSVN-1.9.4.27285"
::1 - - [08/Jul/2016:15:46:59 +0200] "OPTIONS /Test-Group/Sub-Group/Web-Project HTTP/1.1" 500 421 "-" "SVN/1.9.4 (x64-microsoft-windows) serf/1.3.8 TortoiseSVN-1.9.4.27285"
::1 - - [08/Jul/2016:15:48:04 +0200] "OPTIONS /Test-Group/Sub-Group/Web-Project HTTP/1.1" 500 421 "-" "SVN/1.8.13 (x64-microsoft-windows) serf/1.3.8 javahl"
::1 - - [08/Jul/2016:15:56:00 +0200] "OPTIONS /BertLogTest HTTP/1.1" 500 421 "-" "SVN/1.8.13 (x64-microsoft-windows) serf/1.3.8 javahl"
::1 - - [08/Jul/2016:15:57:02 +0200] "OPTIONS /BertLogTest HTTP/1.1" 500 421 "-" "SVN/1.8.13 (x64-microsoft-windows) serf/1.3.8 javahl"

NOTE: The reference to the folder: /home/rcdev/repositories_store/BertLogTest/format, there is no folder named BertLogTest in /home/rcdev/repositories_store (there are no folders at all there). The permissions on that folder are:
drwxrwxr-x 2 rcdev rcdev 4096 Oct 1 2015 repositories_store

#3 Updated by Marcin Kuzminski [staff] about 3 years ago

Hi Bert,

Hmm this is strange, have you created any projects inside RhodeCode ? There should be visible in the /home/rcdev/repositories_store
Is that directory empty ? Have you created any projects inside RhodeCode already ? (in root level or in groups ?)

#4 Updated by Bert Zahniser about 3 years ago

Hi Marcin,

I just spoke to Robbie. He has uploaded files into a repository through the web gui so far. He was trying to connect to a repository through eclipse and tortoiseSVN to browse the repository when he got the 500 error.

Our repo directory is defined as /data in the admin interface and I can see folders getting created in that hierarchy. I don't understand why the logs indicate it is looking for the SVN repo in /home/rcdev.

Raj said he is available this afternoon if you wanted to connect in via a Webex to debug. He can create a webex session on demand.

Bert

#5 Updated by Bert Zahniser about 3 years ago

1237

Attached is the error we are getting.

#6 Updated by Marcin Kuzminski [staff] about 3 years ago

Hi Bert,

I believe this is due that the proxy is configured on the absolute path of /home/rcdev inside Apache config, and you change the repository path to /data
That probably need to be adjusted. Let me Know if we should make a webex today.

ps. please also try to upgrade to latest version we did some svn improvements there as well.

#7 Updated by Bert Zahniser about 3 years ago

Hi Marcin,

I updated the apache2 configuration and it is working for newly created repositories. Repos that were created before the config change still generate errors but since we were just testing we did not have anything we needed in those repos yet.

We are running 4.2.1 currently and the interface reports this as being the current version when we do a "check for updates".

Thanks!
Bert Zahniser

#8 Updated by Marcin Kuzminski [staff] about 3 years ago

Bert, good news :)

We already opened a ticket to create those configs automatically based on RC events. So hopefully this could be much easier in the next releases.

https://issues.rhodecode.com/issues/4082

#9 Updated by Marcin Kuzminski [staff] about 3 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF