Project

General

Profile

Bug #5628

Problems with SSH Connection docs

Added by Russell Warren about 1 month ago.

Status:
New
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
02.07.2020
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

In going through setup of the SSH connection for a new CE server I ran into a few problems worthy of feedback.

Docs I followed are here:

https://docs.rhodecode.com/RhodeCode-Enterprise/auth/ssh-connection.html

Problems I encountered:

1. Confusion between EE and CE

"EE" is clearly Enterprise Edition
"CE" is clearly Community Edition

This differentiation is very clear A) on the RhodeCode website in multiple places (e.g. here), and B) in general usage.

SSH Connection docs cclearly reference "RhodeCode Enterpise" multiple times, making it seem like it is not available in CE.

I was told on the slack help channel that the naming is "RhodeCode Enterprise EE" (or CE), which is very confusing.

Also see bug #5625 where I ran into similar confusion.

**2. Step 1 is confusing, and the existence of .ssh/authorized_keys_rhodecode itself is also confusing

Step 1 should be rewritten to clarify that that file will be needed (but does not exist yet), and that a separate non-standard authorized_keys file is recommended in order for rhodecode to be able to modify it diectly without affecting the standard system file (I assume thisis the reason). It should also be restated here that running as an isolated rhodecode user is highly recommended (in which case a separate authorized_keys file woudl not be needed, nor would modifying the system sshd config!!).

My confusion was:

A) I thought the file should exist (since it explicitly says "By default a file authorized_keys_rhodecode is created containing configuration"), but it does not
B) Why was a separate authorized_keys file needed in the first place? (I am using a rhodecode user, and expected RhodeCode to use this and not need me to tweak my system /etc/ssh/sshd_config)

3. The /home/rhodecode/.ssh/ dir is not created automatically

After following directions explicitly, I expected that adding an ssh key would work for my user. It did not, and I got the following error in red at the top of the my_account/ssh_keys UI:

An error occurred during ssh key saving: [Errno 2] No such file or directory: '/home/rhodecode/.ssh/authorized_keys_rhodecode'

Your docs state "This will generate a new entry inside our configured authorized_keys_rhodecode file", but the receiving ~/.ssh/ does not exist, nor does the authorized_keys_rhodecode file.

This did seem to be registered (in the database?), since when I created the dir to retry, I could not re-add without deleting the existing entry.

Creating the ~/.ssh dir manually fixes the problem. I did not need to create an empty authorized_keys_rhodecode file.

Also available in: Atom PDF