Project

General

Profile

Bug #5436

Unable To Open Pull Request in 4.11.2

Added by Peter Rebholz almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
-
Target version:
-
Start date:
09.02.2018
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

I upgraded our testing environment to 4.11.2 in order to see if issue #5414 was addressed. I'm unable to successfully open a pull request as there are a few issues in the way:

  • When selecting a commit from the Changelog and clicked "open new pull request for selected commit", the source ref field is not set with the commit/bookmark I selected on the Changelog page
  • I can't appear to ever select a target revision. It's always blank and clicking on it does not display a drop down.

I noticed an error in the JS console that prints once initially and whenever I change the target repository: TypeError: selectedRef is null. My initial thought was maybe a browser caching issue but after clearing my cache, that doesn't seem to address the issue.

History

#1 Updated by Marcin Kuzminski [staff] almost 2 years ago

Hi Peter,

I'm unable to reproduce this on mercurial/git repos via branch/fork workflow.

Could you show the cut screen of the changelog references/DAG graph on how the commits look like?

It looks like JS/Static file issues. Could it be your HTTP server cached those somehow?

#2 Updated by Peter Rebholz almost 2 years ago

Hi Marcin,

After poking around a bit more, it seems to happen when the default branch is closed. Things seem to be working for repositories that have the default.

Steps to reproduce:

  1. Create a repo; make some commits; create a new branch and make some commits; push to RhodeCode
  2. Fork repository; clone and make some commits; push
  3. Try to open a pull request from the fork. Everything works.
  4. In the original repository, close the default branch and push
  5. Try to open a pull request from the fork. Source revision is not selected and target box is blank
  6. In the original repository, re-open the default branch and push
  7. Try to open a pull request from the fork. Everything is working again

#3 Updated by Marcin Kuzminski [staff] almost 2 years ago

Hi Peter,

Thanks for the details. It's odd because we tested the "closed" brach case for you, but let us get back to this and i'll let you know.

#4 Updated by Marcin Kuzminski [staff] almost 2 years ago

Ok, confirmed.

We'll fix the case on JS side and make a release for that probably today/tomorrow.

#5 Updated by Redmine Integration almost 2 years ago

  • Status changed from New to Resolved

#6 Updated by Marcin Kuzminski [staff] almost 2 years ago

We just released 4.11.3 version that addresses this case.

Also available in: Atom PDF