Project

General

Profile

Bug #5405

Add repository from UI leads to HTTP/404

Added by Jarno Kanto almost 2 years ago. Updated almost 2 years ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
28.11.2017
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

When add new reposiitory from UI it shows HTTP/404 error page even repository is created as expected.

Installation is Rhodecode 4.10.5 with Celery, RabbitMQ and Postgres as database.
Same setup with version 4.9.0 is working fine.

snippet from community.log:

[28/Nov/2017:10:23:49 +0000] GNCRN <7378>   127.0.0.1       rqt:0.261262 302 234 "POST:/_admin/repos/create " usr:- "https://192.168.33.171/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36"
2017-11-28 10:23:49.283 INFO  [rhodecode.lib.middleware.request_wrapper] IP: 192.168.33.1 Request to /testi3/repo_creating time: 0.105s
[28/Nov/2017:10:23:49 +0000] GNCRN <7378>   127.0.0.1       rqt:0.111062 404 2689 "GET:/testi3/repo_creating task_id=31b01c11-08f0-44ac-ae4d-6cb6fbf6002e" usr:- "https://192.168.33.171/" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36"
2017-11-28 10:23:49.829 INFO  [rhodecode.lib.middleware.request_wrapper] IP: 192.168.33.1 Request to /_static/rhodecode/css/style.css time: 0.412s
[28/Nov/2017:10:23:49 +0000] GNCRN <7378>   127.0.0.1       rqt:0.418931 200 - "GET:/_static/rhodecode/css/style.css " usr:- "https://192.168.33.171/testi3/repo_creating?task_id=31b01c11-08f0-44ac-ae4d-6cb6fbf6002e" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36"
2017-11-28 10:23:50.075 INFO  [rhodecode.lib.middleware.request_wrapper] IP: 192.168.33.1 Request to /_static/rhodecode/images/RhodeCode_Logo_Black.png time: 0.186s
[28/Nov/2017:10:23:50 +0000] GNCRN <7378>   127.0.0.1       rqt:0.265793 200 - "GET:/_static/rhodecode/images/RhodeCode_Logo_Black.png " usr:- "https://192.168.33.171/testi3/repo_creating?task_id=31b01c11-08f0-44ac-ae4d-6cb6fbf6002e" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36"
2017-11-28 10:23:50.189 INFO  [rhodecode.lib.middleware.request_wrapper] IP: 192.168.33.1 Request to /_static/rhodecode/js/scripts.js time: 0.519s
[28/Nov/2017:10:23:50 +0000] GNCRN <7377>   127.0.0.1       rqt:0.554409 200 - "GET:/_static/rhodecode/js/scripts.js " usr:- "https://192.168.33.171/testi3/repo_creating?task_id=31b01c11-08f0-44ac-ae4d-6cb6fbf6002e" "Mozilla/5.0 (Macintosh; Intel Mac OS X 10_12_6) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36"

Attached Vagrantfile and provision script for easy reproduce:
1) vagrant up
2) log in as admin
3) Add repository -> 404

Vagrantfile (429 Bytes) Vagrantfile Vagrant file for easy reproduce of the issue Jarno Kanto, 28.11.2017 11:29
provision.sh (5.83 KB) provision.sh provisionscript for Vagrant Jarno Kanto, 28.11.2017 11:29

History

#1 Updated by Marcin Kuzminski [staff] almost 2 years ago

Hi,

We're aware of this issue with celery and async repo creation. The repository gets created however 404 is on checker of repo. We'll fix this on next bugfix release.

Also available in: Atom PDF