Project

General

Profile

Bug #5337

Possible memory leak after few Git Pull Requests

Added by Alexis Jeandet over 2 years ago. Updated about 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
15.06.2017
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

On our instance of Rhodecode (server 24 thread 32GB Ram) we saw at least since Rhodecode 4.6+ a weird behaviour:

After few PR( something like 10) the server start to produce errors randomly on pages browsing, sometimes refreshing works.

If I restart both VCS and Rhodecode EE instance the problem disappear. (Not sure which one solves the problem, to be checked next time).
When I start Rhodecode the used memory rise at ~20GB when the bug appear 24GB is used.

We can also say that without PR the server run for months without problem.
We mainly use PR with Git now.
We use Rhodecode 4.7.2.

History

#2 Updated by Marcin Kuzminski [staff] over 2 years ago

  • Target version set to v4.8

#3 Updated by Marcin Kuzminski [staff] over 2 years ago

  • Status changed from New to In Progress

#4 Updated by Marcin Kuzminski [staff] over 2 years ago

At least we can confirm that the problem is inside the rich diff parser, also part of the problem is really big files in your repos like some .tmp 30 000 lines text files.

We'll investigate further...

#5 Updated by Marcin Kuzminski [staff] over 2 years ago

  • Target version changed from v4.8 to v4.10

We added some fixes that will be in 4.8 release. It doesn't fully fix the problem but it reduces memory footprint by arround 30%.

We still have work to do there

#6 Updated by Marcin Kuzminski [staff] about 2 years ago

  • Status changed from In Progress to Resolved

Also available in: Atom PDF