Project

General

Profile

Support #4243

Gist visibility update?

Added by Marcin Kuzminski [staff] about 3 years ago. Updated about 3 years ago.

Status:
Resolved
Priority:
High
Category:
-
Target version:
Start date:
30.08.2016
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

[tenderapp] report: https://rhodecode.tenderapp.com/help/discussions/questions/33218 reported by user: rhodecode@x.keshi.org

When I edit an existing public gist entry, it always turns into a private gist without any indications. And there seems no way to change the visibility of gists from private to public. Is this an intended behavior?

Confirmed with my own RhodeCode CE 4.3.1 installation and https://code.rhodecode.com.

How to reproduce:

  1. Sign in to https://code.rhodecode.com/.
  2. Open https://code.rhodecode.com/_admin/gists/new.
  3. Fill anything in the body and push "Create Public Gist" button.
  4. Push "Edit" button.
  5. Push "Update Gist" button.

Expected result:

  • The gist entry should remain public.

Actual result:

  • The gist entry turns into "Private Gist".

History

#1 Updated by Marcin Kuzminski [staff] about 3 years ago

Hi !

Thanks for reporting this, we will fix this ASAP, and produce a bugfix release in next 1-2 days.

#2 Updated by Marcin Kuzminski [staff] about 3 years ago

  • Private changed from Yes to No
  • Target version set to v4.5
  • Priority changed from Normal to High
  • Assignee set to Marcin Kuzminski [staff]

#3 Updated by Martin Bornhold about 3 years ago

  • Assignee changed from Marcin Kuzminski [staff] to Martin Bornhold

#4 Updated by Redmine Integration about 3 years ago

pullrequest created by martinb (status: under_review). https://internal-code.rhodecode.com/rhodecode-enterprise-ce/pull-request/2725

#8 Updated by Martin Bornhold about 3 years ago

  • Status changed from In Progress to Resolved

The problem was a wrong default value in the colander schema. On edit we don't send a value for the type attribute and therefore an invalid default value get's inserted into the DB, only 'private' or 'public' are allowed. When filtering with 'private' or 'public' the gists with invalid values are "hidden".
Fixed with https://internal-code.rhodecode.com/rhodecode-enterprise-ce/pull-request/2725

Also available in: Atom PDF