Project

General

Profile

Bug #4116

[ee] Starting EE or running paster commands like setup-rhodecode does not work without setting LC_ALL properly.

Added by Martin Bornhold about 2 years ago. Updated about 2 years ago.

Status:
New
Priority:
High
Assignee:
-
Category:
-
Target version:
Start date:
22.07.2016
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

Running EE with pserve or paster commands like setup-rhodecode command works only if i set export LC_ALL=en_US.UTF-8
Steps to reproduce the error:

export LC_ALL=''
paster setup-rhodecode --user=admin --email=admin@example.com --password=secret --api-key=9999999999999999999999999999999999999999 http_waitress.ini

or

export LC_ALL=''
pserve http_waitress.ini

History

#1 Updated by Martin Bornhold about 2 years ago

Traceback:

[nix-shell:~/work/ee]$ paster setup-rhodecode      --user=admin      --email=admin@example.com      --password=secret      --api-key=9999999999999999999999999999999999999999      http_waitress.ini
/nix/store/q4hvx3338li7cn0i4qkjwiq999lnyggn-python2.7-celery-2.2.10/lib/python2.7/site-packages/celery/loaders/default.py:54: NotConfigured: No 'celeryconfig' module found! Please make sure it exists and is available to Python.
  "is available to Python." % (configname, )))
Traceback (most recent call last):
  File "/nix/store/ybpg2k6jzn5lyipag2r7bb8lf3y0kijl-python2.7-PasteScript-1.7.5/bin/.paster-wrapped", line 12, in <module>
    sys.exit(run())
  File "/nix/store/ybpg2k6jzn5lyipag2r7bb8lf3y0kijl-python2.7-PasteScript-1.7.5/lib/python2.7/site-packages/paste/script/command.py", line 104, in run
    invoke(command, command_name, options, args[1:])
  File "/nix/store/ybpg2k6jzn5lyipag2r7bb8lf3y0kijl-python2.7-PasteScript-1.7.5/lib/python2.7/site-packages/paste/script/command.py", line 143, in invoke
    exit_code = runner.run(args)
  File "/nix/store/ybpg2k6jzn5lyipag2r7bb8lf3y0kijl-python2.7-PasteScript-1.7.5/lib/python2.7/site-packages/paste/script/appinstall.py", line 68, in run
    return super(AbstractInstallCommand, self).run(new_args)
  File "/nix/store/ybpg2k6jzn5lyipag2r7bb8lf3y0kijl-python2.7-PasteScript-1.7.5/lib/python2.7/site-packages/paste/script/command.py", line 238, in run
    result = self.command()
  File "/nix/store/plqjcbni1rnj0fvq904kisaag9d3b8jl-python2.7-rhodecode-enterprise-ce-4.3.0/lib/python2.7/site-packages/rhodecode/lib/paster_commands/setup_rhodecode.py", line 132, in command
    conf = appconfig(config_spec, relative_to=os.getcwd())
  File "/nix/store/c8c076f6v2slbi2jzyzcaa6ijab458pw-python2.7-PasteDeploy-1.5.2/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 261, in appconfig
    global_conf=global_conf)
  File "/nix/store/c8c076f6v2slbi2jzyzcaa6ijab458pw-python2.7-PasteDeploy-1.5.2/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 296, in loadcontext
    global_conf=global_conf)
  File "/nix/store/c8c076f6v2slbi2jzyzcaa6ijab458pw-python2.7-PasteDeploy-1.5.2/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 320, in _loadconfig
    return loader.get_context(object_type, name, global_conf)
  File "/nix/store/c8c076f6v2slbi2jzyzcaa6ijab458pw-python2.7-PasteDeploy-1.5.2/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 454, in get_context
    section)
  File "/nix/store/c8c076f6v2slbi2jzyzcaa6ijab458pw-python2.7-PasteDeploy-1.5.2/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 476, in _context_from_use
    object_type, name=use, global_conf=global_conf)
  File "/nix/store/c8c076f6v2slbi2jzyzcaa6ijab458pw-python2.7-PasteDeploy-1.5.2/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 406, in get_context
    global_conf=global_conf)
  File "/nix/store/c8c076f6v2slbi2jzyzcaa6ijab458pw-python2.7-PasteDeploy-1.5.2/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 296, in loadcontext
    global_conf=global_conf)
  File "/nix/store/c8c076f6v2slbi2jzyzcaa6ijab458pw-python2.7-PasteDeploy-1.5.2/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 328, in _loadegg
    return loader.get_context(object_type, name, global_conf)
  File "/nix/store/c8c076f6v2slbi2jzyzcaa6ijab458pw-python2.7-PasteDeploy-1.5.2/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 620, in get_context
    object_type, name=name)
  File "/nix/store/c8c076f6v2slbi2jzyzcaa6ijab458pw-python2.7-PasteDeploy-1.5.2/lib/python2.7/site-packages/paste/deploy/loadwsgi.py", line 646, in find_egg_entry_point
    possible.append((entry.load(), protocol, entry.name))
  File "/nix/store/44ph5kird5imqrvw5nx9fg7bbkwdi80g-python2.7-setuptools-19.4/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 2369, in load

  File "/nix/store/44ph5kird5imqrvw5nx9fg7bbkwdi80g-python2.7-setuptools-19.4/lib/python2.7/site-packages/setuptools-19.4-py2.7.egg/pkg_resources/__init__.py", line 2375, in resolve

  File "/Users/mb/work/ee/rc_ee/__init__.py", line 2, in <module>
    from .config import make_pyramid_app
  File "/Users/mb/work/ee/rc_ee/config.py", line 2, in <module>
    from rhodecode.config import middleware as ce_middleware
  File "/nix/store/plqjcbni1rnj0fvq904kisaag9d3b8jl-python2.7-rhodecode-enterprise-ce-4.3.0/lib/python2.7/site-packages/rhodecode/config/middleware.py", line 42, in <module>
    import rhodecode.integrations # do not remove this as it registers celery tasks
  File "/nix/store/plqjcbni1rnj0fvq904kisaag9d3b8jl-python2.7-rhodecode-enterprise-ce-4.3.0/lib/python2.7/site-packages/rhodecode/integrations/__init__.py", line 23, in <module>
    from rhodecode.integrations.types import webhook, slack
  File "/nix/store/plqjcbni1rnj0fvq904kisaag9d3b8jl-python2.7-rhodecode-enterprise-ce-4.3.0/lib/python2.7/site-packages/rhodecode/integrations/types/slack.py", line 33, in <module>
    from rhodecode.lib import helpers as h
  File "/nix/store/plqjcbni1rnj0fvq904kisaag9d3b8jl-python2.7-rhodecode-enterprise-ce-4.3.0/lib/python2.7/site-packages/rhodecode/lib/helpers.py", line 77, in <module>
    from rhodecode.lib.markup_renderer import MarkupRenderer
  File "/nix/store/plqjcbni1rnj0fvq904kisaag9d3b8jl-python2.7-rhodecode-enterprise-ce-4.3.0/lib/python2.7/site-packages/rhodecode/lib/markup_renderer.py", line 33, in <module>
    from docutils.core import publish_parts
  File "/nix/store/9bcgrmzqp8a466f0ir71i4s9gwdyvyx8-python2.7-docutils-0.12/lib/python2.7/site-packages/docutils/core.py", line 20, in <module>
    from docutils import frontend, io, utils, readers, writers
  File "/nix/store/9bcgrmzqp8a466f0ir71i4s9gwdyvyx8-python2.7-docutils-0.12/lib/python2.7/site-packages/docutils/frontend.py", line 41, in <module>
    import docutils.utils
  File "/nix/store/9bcgrmzqp8a466f0ir71i4s9gwdyvyx8-python2.7-docutils-0.12/lib/python2.7/site-packages/docutils/utils/__init__.py", line 20, in <module>
    import docutils.io
  File "/nix/store/9bcgrmzqp8a466f0ir71i4s9gwdyvyx8-python2.7-docutils-0.12/lib/python2.7/site-packages/docutils/io.py", line 18, in <module>
    from docutils.utils.error_reporting import locale_encoding, ErrorString, ErrorOutput
  File "/nix/store/9bcgrmzqp8a466f0ir71i4s9gwdyvyx8-python2.7-docutils-0.12/lib/python2.7/site-packages/docutils/utils/error_reporting.py", line 47, in <module>
    locale_encoding = locale.getlocale()[1] or locale.getdefaultlocale()[1]
  File "/nix/store/d8p5yybndxr14n7xbrbwr4l9ksviwvyz-python-2.7.11/lib/python2.7/locale.py", line 543, in getdefaultlocale
    return _parse_localename(localename)
  File "/nix/store/d8p5yybndxr14n7xbrbwr4l9ksviwvyz-python-2.7.11/lib/python2.7/locale.py", line 475, in _parse_localename
    raise ValueError, 'unknown locale: %s' % localename
ValueError: unknown locale: UTF-8

#2 Updated by Martin Bornhold about 2 years ago

  • Description updated (diff)
  • Subject changed from [dev-env] The paster command setup-rhodecode does not work without setting LC_ALL properly. to [ee] Starting EE or running paster commands like setup-rhodecode does not work without setting LC_ALL properly.

#3 Updated by Marcin Kuzminski [staff] about 2 years ago

  • Target version changed from v4.3 to v4.4

#4 Updated by Marcin Kuzminski [staff] about 2 years ago

  • Priority changed from Normal to High

We got some new report on this: https://rhodecode.tenderapp.com/help/discussions/problems/9592-problem-with-running-vcsserver-1-after-upgrade-rh-from-421-to-430

I'm bumping this issue, to be checked. Unable to run vcsserver is critical.

Also available in: Atom PDF