Project

General

Profile

Support #4104

Switch to commit in file view PB

Added by Marcin Kuzminski [staff] about 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Start date:
18.07.2016
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

[tenderapp] report: https://rhodecode.tenderapp.com/help/discussions/problems/9564 reported by user: alexis.jeandet@lpp.polytechnique.fr

Hi,

When we browse our repository in the file view, the "switch to commit" combo box seems to redirect us to a bad address.

With this repository(public):
https://hephaistos.lpp.polytechnique.fr/rhodecode/HG_REPOSITORIES/LPP/INSTRUMENTATION/USERS/JEANDET/qtcharts
jumping to 5.6 branch redirects to:
https://hephaistos.lpp.polytechnique.fr/rhodecode/qtcharts/files/5.6/?at=5.6
instead of:
https://hephaistos.lpp.polytechnique.fr/rhodecode/HG_REPOSITORIES/LPP/INSTRUMENTATION/USERS/JEANDET/qtcharts/files/5.6/?at=5.6

It just skip all the sub-repositories in the path.

Best regards,
Alexis.

History

#1 Updated by Marcin Kuzminski [staff] about 3 years ago

  • Target version set to v4.2
  • Priority changed from Normal to High
  • Assignee set to Martin Bornhold

#2 Updated by Marcin Kuzminski [staff] about 3 years ago

  • Private changed from Yes to No

#3 Updated by Martin Bornhold about 3 years ago

I can confirm that. I reproduced it locally at least for hg and git repositories which are inside a repository group, doesn't matter if it is deeply nested or only one level. From the first investigations i can say that the form points to the correct URL but in the end you are getting a 404 with the leading repository groups stripped from URL. I am now looking into that to find the cause.

#4 Updated by Martin Bornhold about 3 years ago

  • Status changed from In Progress to Resolved

URL generation lacks the repository group. This is fixed and is contained in https://internal-code.rhodecode.com/rhodecode-enterprise-ce/pull-request/2462

#7 Updated by Martin Bornhold about 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF