Project

General

Profile

Bug #3549

[4.0.0 regression], file source links use last commit id instead of current commit id

Added by Marcin Kuzminski [staff] over 3 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Category:
-
Target version:
-
Start date:
21.04.2016
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

Case:

You're browsing a file tree at tag v2.2.8 - commit id XXX

When entering particular file (lets say setup.py), the links and headers are based on the last commit (YYY) of file instead of the XXX.

This causes few problems:

  • the commit info suddenly changes when moving from tree view, to file view, since all info is taken from YYY
  • references suddenly change, so you're puzzled why the tag reference is suddenly missing, again since references are calculated from YYY
  • links like raw, annotate etc uses the last commit id (YYY), and clicking on them actually can show you totally different things since YYY can be a different branch last edit.

We should always use XXX since this is the file tree you're browsing AT, and all things should be poiting to this commit.

I would also add additional link to what's the last commit of file, after XXX that will show YYY, so one can tell if actual XXX commit is one that changed file setup.py

History

#1 Updated by Marcin Kuzminski [staff] over 3 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF