Project

General

Profile

Actions

Bug #3457

closed

[vcs, unicode] Unicode issue during clone of repository

Added by Johannes Bornhold almost 8 years ago. Updated almost 7 years ago.

Status:
Rejected
Priority:
Normal
Category:
-
Target version:
Start date:
08.04.2016
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

Problem:

johannes@Johannes-Mac: ~/w/darwinpkgs/rcpkgs 
$ cd ~/w/

johannes@Johannes-Mac: ~/w 
$ mkdir i-exist-on-fs2

johannes@Johannes-Mac: ~/w 
$ cd /tmp

johannes@Johannes-Mac: /tmp 
$ hg clone http://localhost:5000/i-exist-on-fs2
abort: HTTP Error 404: Not Found

johannes@Johannes-Mac: /tmp 
$ hg init ~/w/i-exist-on-fs2/

johannes@Johannes-Mac: /tmp 
$ hg clone http://localhost:5000/i-exist-on-fs2
http authorization required for http://localhost:5000/i-exist-on-fs2
realm: RhodeCode
user: dev
password: 
abort: HTTP Error 500: Internal Server Error 

It fails with a unicode error on current EE default, on EE stable things are different and I get a forbidden.

Actions #1

Updated by Johannes Bornhold almost 8 years ago

  • Description updated (diff)
2016-04-08 08:15:19.104 ERROR [rhodecode.lib.middleware.simplevcs] Exception while handling request
Traceback (most recent call last):
  File "/Users/johannes/w/momentum/rhodecode/lib/middleware/simplevcs.py", line 179, in __call__
    return self._handle_request(environ, start_response)
  File "/Users/johannes/w/momentum/rhodecode/lib/middleware/simplevcs.py", line 268, in _handle_request
    result = self.authenticate(environ)
  File "/Users/johannes/w/momentum/rhodecode/lib/base.py", line 235, in authenticate
    username, password, environ, auth_modules.VCS_TYPE):
  File "/Users/johannes/w/momentum/rhodecode/lib/auth_modules/__init__.py", line 572, in authenticate
    cache_manager = get_auth_cache_manager(custom_ttl=_cache_ttl)
  File "/Users/johannes/w/momentum/rhodecode/lib/auth_modules/__init__.py", line 495, in get_auth_cache_manager
    'auth_plugins', 'rhodecode.lib.auth_modules', custom_ttl)
  File "/Users/johannes/w/momentum/rhodecode/lib/caches.py", line 64, in get_cache_manager
    return beaker.cache.Cache._get_cache(cache_name, cache_config)
  File "/nix/store/g2fq7dj46xy6dzkv6a9fj42a6qq567pc-python2.7-Beaker-1.7.0/lib/python2.7/site-packages/beaker/cache.py", line 308, in _get_cache
    cache_managers[key] = cache = cls(namespace, **kw)
  File "/nix/store/g2fq7dj46xy6dzkv6a9fj42a6qq567pc-python2.7-Beaker-1.7.0/lib/python2.7/site-packages/beaker/cache.py", line 287, in __init__
    cls = clsmap[type]
  File "/nix/store/g2fq7dj46xy6dzkv6a9fj42a6qq567pc-python2.7-Beaker-1.7.0/lib/python2.7/site-packages/beaker/cache.py", line 69, in __getitem__
    self._init()
  File "/nix/store/g2fq7dj46xy6dzkv6a9fj42a6qq567pc-python2.7-Beaker-1.7.0/lib/python2.7/site-packages/beaker/cache.py", line 106, in _init
    traceback.print_exc(file=tb)
  File "/nix/store/h6z3x9n11hvqdxh8swqvbmba66kib19i-python-2.7.11/lib/python2.7/traceback.py", line 233, in print_exc
    print_exception(etype, value, tb, limit, file)
  File "/nix/store/h6z3x9n11hvqdxh8swqvbmba66kib19i-python-2.7.11/lib/python2.7/traceback.py", line 124, in print_exception
    _print(file, 'Traceback (most recent call last):')
  File "/nix/store/h6z3x9n11hvqdxh8swqvbmba66kib19i-python-2.7.11/lib/python2.7/traceback.py", line 13, in _print
    file.write(str+terminator)
TypeError: unicode argument expected, got 'str'
Actions #2

Updated by Johannes Bornhold almost 8 years ago

  • Description updated (diff)
Actions #3

Updated by Marcin Kuzminski [CTO] almost 8 years ago

  • Assignee set to Marcin Kuzminski [CTO]

I'll take care of it, looks like a bug in cache manager that i introduced.

Actions #4

Updated by Johannes Bornhold almost 8 years ago

  • Target version changed from v4.1 to 124
Actions #5

Updated by Marcin Kuzminski [CTO] over 7 years ago

  • Target version changed from 124 to v4.2
Actions #6

Updated by Marcin Kuzminski [CTO] over 7 years ago

  • Target version changed from v4.2 to v4.3

{{rum(3, Johannes Bornhold)}} can you try to reproduce it ? I cannot

Actions #7

Updated by Marcin Kuzminski [CTO] over 7 years ago

  • Target version changed from v4.3 to v4.4
  • Private changed from Yes to No

moving to 4.4 as we cannot reproduce this, and we're not sure if its fixed.

Actions #8

Updated by Marcin Kuzminski [CTO] over 7 years ago

  • Target version changed from v4.4 to v4.5
Actions #9

Updated by Marcin Kuzminski [CTO] over 7 years ago

  • Target version changed from v4.5 to v4.6
Actions #10

Updated by Marcin Kuzminski [CTO] about 7 years ago

  • Target version changed from v4.6 to v4.7
Actions #11

Updated by Marcin Kuzminski [CTO] almost 7 years ago

  • Status changed from New to Rejected

Rejecting due to lack additional info, and unable to reproduce

Actions

Also available in: Atom PDF