Project

General

Profile

Bug #3375

[timestamps, ux] commit times are off by an hour 😱

Added by Lisa Quatmann over 3 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Category:
-
Target version:
Start date:
24.03.2016
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

When I make a commit and then go to the changelog, the most recent commit is shown an hour ahead, and the tooltip shows it as an hour behind.

See attached; commit was made at 12:21 and the changelog viewed less than a minute later. It should read "1m ago" and the tooltip "Thu, 24 Mar 2016 12:21:20".

History

#1 Updated by Marcin Kuzminski [staff] over 3 years ago

I believe the problem is that the timeago date, is actually without timezone. We need to test and investigate this.

#2 Updated by Lisa Quatmann over 3 years ago

  • Assignee set to Lisa Quatmann
  • Status changed from New to In Progress

#3 Updated by Lisa Quatmann over 3 years ago

  • Assignee deleted (Lisa Quatmann)
  • Status changed from In Progress to New

Putting back to "new" as this is not so simple. Hint: Marcin says that this is due to missing timezone info in our VCSLIB.

#4 Updated by Lisa Quatmann over 3 years ago

  • Assignee set to Marcin Kuzminski [staff]
  • Status changed from New to Resolved

#5 Updated by Marcin Kuzminski [staff] over 3 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF