Project

General

Profile

Support #3226

[support] Mercurial largefiles handling issue

Added by Johannes Bornhold over 6 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
High
Category:
-
Target version:
Start date:
01.03.2016
Due date:
% Done:

0%

Estimated time:
Sorting:
Commit Number:
Affected Version:

Description

Original source: https://rhodecode.tenderapp.com/help/discussions/problems/9447-rc-371-issue-with-lf-for-one-repo

Goals

  • Reproduce and get answers to the questions
  • Follow up if we have issues in this area
#1

Updated by Mikhail Chernykh over 6 years ago

Briefly checked the tenderapp thread. Can be related to the settings priorities.

#2

Updated by Johannes Bornhold over 6 years ago

  • Subject changed from [support] Unknown to [support] Mercurial largefiles handling issue
  • Description updated (diff)
  • Status changed from New to In Progress
#3

Updated by Johannes Bornhold over 6 years ago

Source is: https://rhodecode.tenderapp.com/help/discussions/problems/9447-rc-371-issue-with-lf-for-one-repo

Reproduce the issue

Description from the user

  • I've disabled the LF in the global settings "Admin / Settings / VCS".
  • I've nothing configured regarding LF in the .hgrc.
  • I've created a new repo with LF enabled in "Options / Settings / VCS"
  • When I push a repo with LF on it, I face:

abort: https://server.gemalto.com/hg/toto/ess/repo does not appear to be a largefile store

Local reproduction

  • [X] Start with an empty database
  • [X] Disable largefiles
  • [X] Add a repo
  • [X] enable largefiles for the repo
  • [X] Push largefiles into the repo

Creating an empty system

paster setup-rhodecode dev-empty.ini --user=admin \
    --email=admin@example.com --password=secret --repos=$HOME/tmp/repos-empty

Conclusion

  • Version 3.7.1 is not fit regarding the largefiles setting, we should encourage users to upgrate to 3.8.0 which got a log of improvements in largefiles to make the user experience better.
  • No follow up needed, since we have this fixed and I think that we have this even covered in our ac-tests.
#4

Updated by Johannes Bornhold over 6 years ago

  • Status changed from In Progress to Closed

No work left here, closing this off.

#5

Updated by Marcin Kuzminski [CTO] over 6 years ago

  • Private changed from Yes to No
#6

Updated by Johannes Bornhold over 6 years ago

  • Target version changed from v4.1 to v3.9 - Iteration 32

Releasing done work of Iteration 32

Also available in: Atom PDF